Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

powr stern box ????

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by mudddog91, Jun 7, 2001.

  1. mudddog91

    mudddog91 1/2 ton status

    Joined:
    Dec 28, 2000
    Posts:
    471
    Likes Received:
    0
    Location:
    north carolina
    Hey guys ever have freaky stuff happen to your steering gear box? I put a 2wd sector in my existing box( which im not so sure it was good to begin with}and for about 2 weeks it worked great,then we went wheelin and the pump kept spitting the belt off.Now ive got the correct belt it seems like the steering has a mind of its own,it will turn nice and easy then catch and then get easy again and the pump isnt whining like the belt is slipping,plus yesterday i finally got a chance to look at it and the seal that is around the bottom of the sector shaft(where the pitman arm goes)was popped out? Any ideas? is it the pump or the box or both?
    by the way its a 74
     
  2. mudddog91

    mudddog91 1/2 ton status

    Joined:
    Dec 28, 2000
    Posts:
    471
    Likes Received:
    0
    Location:
    north carolina
    HEY IS THIS QUESTION TOO TECHNICAL OR IS IT A STUPID QUESTION? THANKS FOR ALL THE RESPONSES!!!!!!!!!!!!
     
  3. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,113
    Likes Received:
    1
    Location:
    Western Massachusetts
    It's not a stupid question, nor is it too technical, but most people probably have never had that problem (I know I haven't) so anything we say is merely speculation. I will say that the seal popping out is a definite problem and whatever caused it to pop out may be the reason for the other problems as well. I would replace/fix the seal (hopefully no dirt/crud got in, which if it did, may be the reason for the noises), and give us an update of what's happening. Then we can try to diagnose the problem (especially if we know it keeps spitting seals).

    If you didn't built it yourself, how can you call it yours.......?
     
  4. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    You might try changing the fluid in the pump. Sounds to me like you might have some crud in there. Does the belt still pop off? It's real hard to get that belt tight, so maybe it's to loose. If you press down on the belt, it's only supposed to go down a 1/4" at most. If the belt is tight, then look and make sure the pulley is lined up with the other pulleys. I would start there.

    <font color=red>I'm a psychic amnesiac. I know in advance what I'm going to forget. </font color=red>
     

Share This Page