CK5 Network
Repairing, restoring or modifying your ride just got a whole lot easier!

Crappy start to my day off

fordeater

1/2 ton status
Joined
Mar 21, 2004
Posts
1,402
Reaction score
0
Location
Boerne Tx
Well, i went out this morning to go to walmart, and on the way i saw a buddy of mine at a tire shop, so i decided to stop and say hi. Well, i'm sitting there for a few minutes, when my blazer starts smoking, then the temp gauge rises. So, i shut it off, pop the hood, and then pours out the antifreeze, all over the parking lot. So i waited a minute for it to stop shooting out antifreeze, and then i popped the hood, only to find out that a cap on my radiator, which plugged one of the little pipes coming out of the radiator, had busted completely off. /forums/images/graemlins/angryfire.gif Talk about embarassing. So, we ordered a new cap, and the guys at the tire shop hooked me up with some antifreeze. Whoever converted my rig from manual to auto tranny used some crappy radiator. So, next step for me is find a 4 speed and put it in, and then get a new radiator. I wish i could find out which previous owner converted the damn thing to auto, so i could go exchange words with him. Oh well, $2 and i'm back on the road again.
 

cegusman

3/4 ton status
Joined
Apr 25, 2001
Posts
6,793
Reaction score
0
Location
Houston/Katy, Tx
[ QUOTE ]
/forums/images/graemlins/waytogo.gif (<---pad)

[/ QUOTE ]

I agree /forums/images/graemlins/waytogo.gif (<---pad)
/forums/images/graemlins/dunno.gif
 

fordeater

1/2 ton status
Joined
Mar 21, 2004
Posts
1,402
Reaction score
0
Location
Boerne Tx
I think my day off just got a little worse. Now, i have a bad vibration that seems to come from the motor. I don't know what it is though. I heard a snap, or some kind of noise from the motor, and then the vibration started. It does it when i'm not in gear, and when i'm in gear, but not at low RPM.
 

rcurrier44

1/2 ton status
Joined
Oct 13, 2003
Posts
320
Reaction score
0
Check the fan,fan shroud. I have had 2 fans come apart on me and catch the shroud. After they are missing the blade they start to vibrate at higher RPMs. It will kill your water pump quick!

I had a bad lunch today...my HEI ignitor went out at the post office. Luckly I had an extra one in the box and a test light...was back on the road in 20 min.
 

fordeater

1/2 ton status
Joined
Mar 21, 2004
Posts
1,402
Reaction score
0
Location
Boerne Tx
Dude, you were right on the money. It was the fan. Actually, it was the fan clutch.Its busted up pretty good. Thanks for the tip. Man was i worried. Do i just go to any auto parts store and get a new one or what????
 

mouse

1/2 ton status
Joined
Nov 10, 2003
Posts
1,447
Reaction score
1
Location
Great Falls Mt
Parts store will have it - just plan on big $$$ ($75 or so last time I shopped for one).
 

fordeater

1/2 ton status
Joined
Mar 21, 2004
Posts
1,402
Reaction score
0
Location
Boerne Tx
Alright, after $68, my blazer is back on the road again. Vibration is gone, runs like a charm. Still killed my day off with no way of getting to the parts store until after the wife got home.
 
Top Bottom