Ignition switch problem !!!SOLVED!!!

Discussion in 'The Garage' started by Elevator Man, Jan 31, 2007.

  1. Elevator Man

    Elevator Man 1/2 ton status

    Dec 23, 2005
    Likes Received:
    Bigelow, Arkansas
    All at once the gauges stoped working while I was going down the road. now nothing works that is controlled by the key switch. It did this once before when I was changing the Alt. and didn't unhook the battery. I shorted out the hot wire that goes to the Alt. I tried to start it and nothing worked. I figured it was a fusablelink but never found a bad one. All of the sudden it started working again. Tonight it did it again does anyone know where to start to find this problem?

    Maine ignition wire corroded into. Jacket was still good which made it hard to find, finnaly just started yanking wires and pulled it into and found the bad spot!
    Last edited: Feb 1, 2007
  2. 73k5blazer

    73k5blazer Unplug the matrix cable from the back of your head Premium Member

    Dec 28, 2001
    Likes Received:
    The Rustbelt
    Quite possibly it is your ignition switch.
    It's on the top of the column buried in there.
    Not super hard to get at, there's 2 bolts under the column right behind the metal dash plate, unbolt those and you can pull the whole column down a bit to access the ignition switch.

Share This Page