Stupidest most obvious problems we never see....

Discussion in 'The Garage' started by sled_dog, Oct 28, 2006.

  1. sled_dog

    sled_dog 1 ton status

    Sep 3, 2002
    Likes Received:
    Austin, TX
    Was chasing a parasitic draw in my 97 pickup. Dad's ammeter would PEG when hooked up to the system. The fuse in my digital multimete popped when I tried to, so I assumed(operative word) that there was a bad parasitic draw. Battery would die in hours and be incapable of starting the truck. Limped it to work, tested the battery.... tested bad. Charged it for about an hour. Tested again, still tested bad. Son of a bitch. The brand new Carquest battery(yea not exactly an impressive brand) wouldn't hold a charge. I put the damn thing in trying to fix a problem and it turned out to be junk from the get go. So Carquest replaced the 650CCA battery they sent me originally with a 1020CCA battery. Ok, guess I can accept that. Which hasn't lost a bit of power since I've put it in.
  2. cantolina

    cantolina Newbie

    Apr 5, 2004
    Likes Received:
    Warsaw, NY
    How's this for dumb?

    Went chasing after an ASSUMED vacuum leak in my 4wd actuator system...

    Replaced the switch on the transfer case, replace most ALL of the vacuum lines....still no engagement...

    Then, I remembered that my electric seats and some other accessories stopped working one day, there was an obvious short.....just never got around to tracing it...

    Did it today, just because I was p**sed about not fixing the 4WD....

    Electric seat motor wires were crossed and burnt...

    Took out the seat, fixed the short, replaced the fuse and guess what?

    My 4WD engages again.... :doah:
  3. JohnDeere

    JohnDeere 1/2 ton status

    Jan 17, 2006
    Likes Received:
    Houston, Texas
    no trie this

    I do a tune up new wires rotor and spark plugs.

    had been running rough before

    did that mad a big difference, but it was missing

    looked all over couldnt find it check everything i could

    kept thinking it was my timing that i knocked it lose

    dont have a timeing light so i tried doing it by hear and throtle feel

    helped a little but still miss

    a mounth later my cap went out for some stupid reason

    replaced it and come to find out i had the stupid pulg wires crossed
  4. Russell

    Russell LLY Escalade Status Premium Member GMOTM Winner

    Jun 23, 2000
    Likes Received:
    Edmonton, Alberta
    Spent the last month trying to find a supposive EFI problem with my father's 87 Olds 3.8. Came to find that I had 4 / 6 plug wires hooked up wrong, DOH

    Good news is that if I had found the plug wires to be out sooner, I'd have destroyed the engine. In tearing the engine down to the timing chain, I discovered it to be so horribly worn out that had I had gotten the firing order right on installing the new coil pack it needed, it woulda slipped the chain on the first acceleration, lol

    I guess I just got plain staight up lucky :)

Share This Page