CK5 Network
Become a member of the largest online community for Chevy K5 Blazer, Suburban and C/K series truck owners!

6.2 with a GM8 turbo running poorly

ridenby

1/2 ton status
Premium Member
Joined
Nov 7, 2016
Posts
335
Reaction score
198
Location
kentucky
Engine was running well. Started blowing black smoke. Progressed to black with lot of grey,some puffs of white. Way down on power. Boost gauge was reading vacuum rather than boost. Swapped out turbo with another. Not much change. Still smoking, low on power,boost gauge reading vacuum. Any ideas?
 

Bent77

lil meanie
Staff member
Moderator
GMOTM Winner
Joined
Dec 3, 2002
Posts
35,555
Reaction score
49,229
Location
NoCo
Are all of the lines in the vacuum and boost system in the right place and connected?
Air cleaner need cleaned?
 

ridenby

1/2 ton status
Premium Member
Joined
Nov 7, 2016
Posts
335
Reaction score
198
Location
kentucky
Air cleaner is a cone fabric kn knockoff. Seems clean. No vac lines to turbo. Waste gate tied like the original to truck one.
 

tRustyK5

Big meanie
Staff member
Super Moderator
Moderator
GMOTM Winner
Author
Joined
Jul 23, 2000
Posts
39,899
Reaction score
8,418
Location
E-town baby!
Is the charge pipe intact at every location? Sounds like the output from the turbo isn't making it into the engine...
 

red EOD

1/2 ton status
Premium Member
Joined
Apr 15, 2018
Posts
692
Reaction score
963
Location
Lake Brownwood, Texas
Even without a turbo these can barely smoke like that.

Pull the upper intake manifold off to check for any obstruction, check between the filter/turbo as well.

If they're not obstructed, likely an injector (or multiple) are stuck open.
 

campfire

Adventure is out there!
Premium Member
Joined
Jun 7, 2013
Posts
25,274
Reaction score
14,546
Location
Northwoods Wisconsin / da U.P.
Engine was running well. Started blowing black smoke. Progressed to black with lot of grey,some puffs of white. Way down on power. Boost gauge was reading vacuum rather than boost. Swapped out turbo with another. Not much change. Still smoking, low on power,boost gauge reading vacuum. Any ideas?

Any update on this?
 

ridenby

1/2 ton status
Premium Member
Joined
Nov 7, 2016
Posts
335
Reaction score
198
Location
kentucky
Started truck this morning and was Oh! It healed itself! Took of on a little ride and Bam! black smoke, no power,like to of never made it back to shop. Had some other things that needed taking care of. Will get back to it.
 

campfire

Adventure is out there!
Premium Member
Joined
Jun 7, 2013
Posts
25,274
Reaction score
14,546
Location
Northwoods Wisconsin / da U.P.
Started truck this morning and was Oh! It healed itself! Took of on a little ride and Bam! black smoke, no power,like to of never made it back to shop. Had some other things that needed taking care of. Will get back to it.

Still reading vacuum, even when it was running correctly?
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,580
Reaction score
9,480
Location
iowa
Is it possible the oil to the turbo is plugged and the turbo is locking up? Could explain why a different turbo did the same thing maybe... :dunno:
 

ridenby

1/2 ton status
Premium Member
Joined
Nov 7, 2016
Posts
335
Reaction score
198
Location
kentucky
Still reading vacuum, even when it was running correctly?
It showed neutral. Then went vacuum when it acted up.
Is it possible the oil to the turbo is plugged and the turbo is locking up? Could explain why a different turbo did the same thing maybe... :dunno:
Not sure.
I have 10 NOS injectors,think I will try them.
 
Top Bottom