steering?????

Discussion in 'The Garage' started by jekquistk5, Aug 4, 2004.

  1. jekquistk5

    jekquistk5 Weld nekid Premium Member GMOTM Winner

    Joined:
    Jan 18, 2004
    Posts:
    12,101
    Likes Received:
    2,249
    Location:
    Pinckney, MI
    Build(s):
    3
    Ok,
    Just took the k5 on her first road voyage since the lift and tires, ive got alot of bump steer, and i have alot of play in the steering wheel. From 10-2 its dead, i just put a new PS pump in less then 1k ago. Any suggestions /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif
     
  2. 1-ton

    1-ton 1/2 ton status Premium Member

    Joined:
    Apr 17, 2004
    Posts:
    3,328
    Likes Received:
    462
    Location:
    Las Vegas, Nevada
    Build(s):
    1
    Get a new Steering Gear box.
     
  3. 55chilly's

    55chilly's Newbie

    Joined:
    Feb 12, 2004
    Posts:
    1
    Likes Received:
    0
    what did you do to correct the steering for the lift, is it tight? that or its could be your box. have someone rock the wheel and forth while the engine is off and look for the play-its either in the linkage or the box, the pump has nothing to do with it
     
  4. jekquistk5

    jekquistk5 Weld nekid Premium Member GMOTM Winner

    Joined:
    Jan 18, 2004
    Posts:
    12,101
    Likes Received:
    2,249
    Location:
    Pinckney, MI
    Build(s):
    3
    I used the steering arm correction kit from tuff country. So it could be the box?? i never noticed any play with smaller tires. And should i jack the front end up to check for the play in the linkage?
     

Share This Page