84 K20 "Ethel" 5.3 LS Soon Daily Driver

  1. 6872xtc

    6872xtc make mine modified Premium Member GMOTM Winner

    Joined:
    Sep 16, 2008
    Posts:
    4,933
    Likes Received:
    4,233
    Location:
    Palisade,Colorado
    Build(s):
    1
    I'm here, but not sure what I have to do with this

    :dunno:
    :haha:

    @AgDieseler maybe?
     
    sreidmx and AgDieseler like this.
  2. MetalMulishaMarcus

    MetalMulishaMarcus 1 Ton Status Premium Member

    Joined:
    Jul 22, 2017
    Posts:
    535
    Likes Received:
    261
    Location:
    Disneyland
    They are talking about Dave on YouTube. His YouTube name is Dicks4x4. Hes been doing live videos with Steve on wednesdays and sundays.
    Dave is a squarebody guy but has making his way into Heeps...I mean jeeps..lol...
     
    sreidmx, AgDieseler and 6872xtc like this.
  3. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Hi guys!! Thank you for sitting in on our shenanigans!!
     
  4. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Ordered this today for Ethel! I got 40+K out of my last set which I bought in 5/15 which I can’t belieeb!!
    Pretty stoked because they look pretty damn good.
    54B01426-7B61-4D88-BE14-5EEC72E7C48D.jpeg
     
  5. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Weird find this weekend. Plugged in spare ecm and the bounce did not go away, so we’re thinking it might be a bad throttle body.. weird because I drove it 480 miles without a single issue and 100 miles of that was towing jakes blazer back to my house..
     
  6. Bent77

    Bent77 lil meanie Staff Member Moderator GMOTM Winner

    Joined:
    Dec 3, 2002
    Posts:
    24,388
    Likes Received:
    29,439
    Location:
    colorado
    Build(s):
    1
  7. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Huh?
     
  8. Justin V

    Justin V I should've stayed up there Premium Member GMOTM Winner

    Joined:
    Apr 17, 2016
    Posts:
    4,656
    Likes Received:
    6,306
    Location:
    Colorado
    Build(s):
    1
    Ignition related tempertantrum
     
    sreidmx likes this.
  9. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    No idea
     
  10. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Ethel got new shoos!! It amazing how much this helped the weebles and wobbles!
    AE95EAA7-D7DC-4738-AA71-84D5D5B007D1.jpeg
    Computer still ain’t broke, tempted to run until it does.. or not?? I dunno lol
     
    max 02, ZooMad75 and 6872xtc like this.
  11. Fastereddie

    Fastereddie Sorry if I offended you. Not. Premium Member GMOTM Winner

    Joined:
    Aug 6, 2016
    Posts:
    2,548
    Likes Received:
    3,878
    Location:
    Henderson Nevada
    Build(s):
    1
    Thought you were leaning away from computation box because spare did the same thing?
     
  12. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Correct. Thinking TB but I’ve yet to swap it.. mainly because I’m lazy..
     
  13. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    New TB seemed to have fixed whatever prob was happening, I’m not going to jinx it but I think it’s good.
    Haven’t noticed anything weird since I put it on. I pulled the old one apart and couldn’t really find much that would cause the problem. So I am goin to assume the drive motor was going bad and creating excessive draw on the system. We’ll see how this holds up..
     
  14. Chevy305

    Chevy305 6 Lug 14bsf Status Premium Member GMOTM Winner

    Joined:
    Jan 23, 2006
    Posts:
    11,976
    Likes Received:
    1,181
    Location:
    New Hampshire
    Build(s):
    3
    So where's the burnout video?
     
    Babaganoosh likes this.
  15. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Didn’t work.. stupid thing.. got limp mode parked in the spot at work just before I left for the day.. ordered a new pedal. I’m going to just start throwing parts at it.. next on the list is the harness..
     
  16. Babaganoosh

    Babaganoosh 1 ton status Premium Member GMOTM Winner

    Joined:
    May 30, 2007
    Posts:
    12,610
    Likes Received:
    5,422
    Location:
    Phoenix Arizona
    Build(s):
    2
    What is the issue Steve? Your TPS is off?
     
  17. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    No it is code p2138 http://autocats.ws/manual/chevrolet/tis0911/en/documents_2012/Cruze/SM-T/92293895.EN.html

    Explained more in depth here. But I am going to recheck my harness and see if that results in something different. I’ve replaced the plug at the pedal, I ran all new wires from the ecu.. replaced the TB so I dunno what it could be at this point other than some weird back feeding or something I can’t see..
     
  18. Babaganoosh

    Babaganoosh 1 ton status Premium Member GMOTM Winner

    Joined:
    May 30, 2007
    Posts:
    12,610
    Likes Received:
    5,422
    Location:
    Phoenix Arizona
    Build(s):
    2
    Replace the pedal, that's the common issue. I think you can also relearn the sensor as well but not sure how to do it with a swap?

    Does it have a erratic idle or one that drops low then back up?
     
    Last edited: Apr 16, 2019 at 12:56 PM
  19. sreidmx

    sreidmx Fortify Offroad Vendor GMOTM Winner

    Joined:
    Oct 24, 2013
    Posts:
    8,199
    Likes Received:
    7,548
    Location:
    Morongo Valley Ca
    Build(s):
    9
    Nope the idle is solid, the pedal is the only thing I haven’t replaced.. hope it’s here tomorrow!

    I relearned the TB when I replaced it.
     
  20. ZooMad75

    ZooMad75 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Apr 5, 2003
    Posts:
    3,273
    Likes Received:
    4,963
    Location:
    Pueblo, CO
    Build(s):
    1
    Before you spend money on an app sensor check the wiring. I've seen our faith share of pedals fail here too, but I've seen just as many where it was a wiring issue too.

    Two key points from the diagnosis is resistance on the circuits and the possibility of a short between app1 circuit and app2 circuit.

    Resistance value for the three circuits to each sensor (low reference, signal and 5v) should be no greater than 5 ohms. High resistance will change your value and if the difference is high enough between app1 and app2 this code sets. This can be a wiring issue or poor connection at either end. We've seen fretting corrosion on terminals (white crusty stuff) that will effect the values. Cleaning the terminals and some dielectric grease usually corrects the corrosion.

    Checking for continuity between any of the circuits is the second item to look for. There should be none.

    If the circuits have good resistance and no continuity to each other, then replace the pedal.
     

Share This Page