Edelbrock Proflo 4

Discussion in 'The Injection Section' started by 6872xtc, Nov 19, 2018.

  1. mrk5

    mrk5 The Sticker Guy Moderator GMOTM Winner Author

    Joined:
    Apr 20, 2004
    Posts:
    20,946
    Likes Received:
    13,261
    Location:
    Northern Colorado
    Build(s):
    2
    I will say for the difficulty cold starting, once it's going, it runs flawlessly. On cold mornings with the carb I had to be careful not to push the throttle too quick or it would die. No problems with that using the PF4.
     
    CharlesC83 and Kain like this.
  2. Kain

    Kain 1/2 ton status Premium Member

    Joined:
    Mar 16, 2011
    Posts:
    4,601
    Likes Received:
    1,285
    Location:
    Lubbock Texas
    Build(s):
    1
    thats exaclty what mine does when it is super cold. Touch the throttle and it dies
     
  3. folkenheath

    folkenheath Volcano Manifolds Vendor GMOTM Winner

    Joined:
    Nov 12, 2004
    Posts:
    5,094
    Likes Received:
    1,350
    Location:
    Wisconsin
    Build(s):
    1
    Sounds like you need to increase the acceleration enrichment for that, can that be increased vs coolant temp with the Edelbrock?

    Sorry I use so many different ones I lose track of what you can do with each sometimes. Of course its easy to see when its in front of me.

    If not increasing the cold temp fuel enrichment will lessen it because it will have more fuel to be running with at that temp and be less picky with throttle changes.
     
    mrk5 likes this.
  4. mrk5

    mrk5 The Sticker Guy Moderator GMOTM Winner Author

    Joined:
    Apr 20, 2004
    Posts:
    20,946
    Likes Received:
    13,261
    Location:
    Northern Colorado
    Build(s):
    2
    Yes, you can adjust acceleration enrichment based on coolant temp.
     
    folkenheath and Kain like this.
  5. Kain

    Kain 1/2 ton status Premium Member

    Joined:
    Mar 16, 2011
    Posts:
    4,601
    Likes Received:
    1,285
    Location:
    Lubbock Texas
    Build(s):
    1
    so i found out i had pump shot duration turned up with fast accell pump and when i turned duration back to 0 it started right up at 16 deg wind chill in the -10 area
     
    JoshHefnerX likes this.
  6. Bent77

    Bent77 lil meanie Staff Member Moderator GMOTM Winner

    Joined:
    Dec 3, 2002
    Posts:
    33,805
    Likes Received:
    45,413
    Location:
    NoCo
    Build(s):
    1
    Hey everyone, invite @centexk5 onto the BroFlo club!
     
    CharlesC83 and Kain like this.
  7. Bent77

    Bent77 lil meanie Staff Member Moderator GMOTM Winner

    Joined:
    Dec 3, 2002
    Posts:
    33,805
    Likes Received:
    45,413
    Location:
    NoCo
    Build(s):
    1
    Checked my cold settings, everything is 0 across the board
     
  8. centexk5

    centexk5 1/2 ton status Premium Member

    Joined:
    Jun 23, 2019
    Posts:
    1,619
    Likes Received:
    2,200
    Location:
    Georgetown, TX
    Build(s):
    1
  9. Bent77

    Bent77 lil meanie Staff Member Moderator GMOTM Winner

    Joined:
    Dec 3, 2002
    Posts:
    33,805
    Likes Received:
    45,413
    Location:
    NoCo
    Build(s):
    1
  10. Bent77

    Bent77 lil meanie Staff Member Moderator GMOTM Winner

    Joined:
    Dec 3, 2002
    Posts:
    33,805
    Likes Received:
    45,413
    Location:
    NoCo
    Build(s):
    1
    Want a number for our not so secret club? @6872xtc is handing out numbers
     
  11. centexk5

    centexk5 1/2 ton status Premium Member

    Joined:
    Jun 23, 2019
    Posts:
    1,619
    Likes Received:
    2,200
    Location:
    Georgetown, TX
    Build(s):
    1
    Sure. Can I use it in the lotto?
     
    Bent77 likes this.
  12. mrk5

    mrk5 The Sticker Guy Moderator GMOTM Winner Author

    Joined:
    Apr 20, 2004
    Posts:
    20,946
    Likes Received:
    13,261
    Location:
    Northern Colorado
    Build(s):
    2
    So far making cold start enrichment changes 1% at a time hasn't helped with my cold start issues. The routine now is to crank then give it a little pedal to keep it idling until the O2 sensor is warm and running in closed loop.

    I'm thinking maybe it needs just the right combination of cold start enrichment and crank fuel. It's frustrating to pin down because you don't get any real feedback from the system until the O2 sensor is heated up. Or there is something else causing the trouble. All other operations are basically flawless.
     
  13. 6872xtc

    6872xtc make mine modified Premium Member GMOTM Winner

    Joined:
    Sep 16, 2008
    Posts:
    7,147
    Likes Received:
    7,040
    Location:
    Palisade,Colorado
    Build(s):
    1
    I could smell that mine was rich this morning. I didn't look at anything after it was running. My nose was the fuel sensor since the tailpipe is on the driver side of a short wheelbase truck. The oxygen around me didn't smell quite right.
    :D
    It didn't stall when I dropped it into gear after letting it warm up a few minutes. Probably about 5 minutes, and it was 28*.

    And I am not in charge of handing out numbers. There would several #1s though.
     

Share This Page